Exontrol.ExResizer - Information, Features

ExResizer

The ExResizer allows you to resize controls in a form proportionally or maintain the components' anchored sizes and positions. ExReSize alters the sizes and positions of controls on Visual Basic forms as they are sized, without requiring you to write any code! Simply drop the control onto the form, and you instantly have the ability to resize any control proportionally, by selecting the Anchor property. The way how a control can be anchored to one of more container edges is more than intuitive.

Features include:

  • finds all controls on your form
  • handles every type of component: lines, shapes, controls, ActiveX
  • each control can anchor to the left, top, right and bottom of its container
  • handles Tabs (like SSTab control), as well as any other container
  • resizing controls work on runtime as well in design time
  • no code required to anchor the control to one or more container edges
  • minimum and maximum form size
  • no design limitations
  • its easy to implement resize capabilities to your already built forms
  • ATL based, minimal dependencies, fast execution, no MFC required

® ExResizer is a trademark of Exontrol. All Rights Reserved.


Exontrol - Support

How to get support?

To keep your business applications running, you need support you can count on.

Here are few hints what to do when you're stuck on your programming:

  • Check out the samples - they are here to provide some quick info on how things should be done
  • Check out the how-to questions using the eXHelper tool
  • Check out the help - includes documentation for each method, property or event
  • Check out if you have the latest version, and if you don't have it send an update request here.
  • Submit your problem(question) here.

Don't forget that you can contact our development team if you have ideas or requests for new components, by sending us an e-mail at support@exontrol.com ( please include the name of the product in the subject, ex: exgrid ) . We're sure our team of developers will try to find a way to make you happy - and us too, since we helped.

Regards,
Exontrol Development Team

https://www.exontrol.com


Resizer object
Tip The /COM object can be placed on a HTML page (with usage of the HTML object tag: <object classid="clsid:...">) using the class identifier: {95541EA1-31B3-4721-86B0-BBC140C7059A}. The object's program identifier is: "Exontrol.Resizer". The /COM object module is: "ExResizer.dll"
The ExResizer allows you to resize controls in a form proportionally or maintain the components' anchored sizes and positions. The ExResizer alters the sizes and positions of controls on Visual Basic forms as they are sized. Here's the list of supported properties and methods:

Name | Description
Anchor | Gets or sets which edges of the control(s) are anchored to the edges of its container.
Enabled | Retrieves or sets a value that indicates whether the control is enabled or disabled.
FormMaxHeight | Retrieves or sets a value that indicates the maximum height for the form.
FormMaxWidth | Retrieves or sets a value that indicates the maximum width for the form.
FormMinHeight | Retrieves or sets a value that indicates the minimum height for the form.
FormMinWidth | Retrieves or sets a value that indicates the minimum width for the form.
ObjectAnchor | Retrieves or sets a value that indicates the object's anchor value.
Refresh | Refreshes the objects coordinates.
Update | Updates the position and size for each anchored control.


property Anchor

property Resizer.Anchor as String
Gets or sets which edges of the control(s) are anchored to the edges of its container.

Type | Description
String | A string expression that is used by control to serialize the components and anchor value for each of them. Use the Anchor Property Page to change the Anchor property at design time

The Anchor property provides an Anchor Property Page that can be used to change the component's anchor at design time. Also, the control provides an additional context menu item that can be used to call the Anchor Property Page. Using the Anchor Property Page the user select a component and can set the component edges that are anchored to the edges of its container. You can use also ObjectAnchor property to set the component's anchor at runtime.


property Enabled

property Resizer.Enabled as Boolean
Retrieves or sets a value that indicates whether the control is enabled or disabled.

Type | Description
Boolean | A boolean expression that indicates whether the ExResizer is enabled or disabled.

By default, the Enabled property is True. The control doesn't resize any components in the container, while the Enabled property is False.


property FormMaxHeight

property Resizer.FormMaxHeight as Single
Retrieves or sets a value that indicates the maximum form height.

Type | Description
Single | A numeric value that indicates the maximum form height, in form coordinates.

The FormMaxHeight property specifies the maximum height for the form. If the FormMaxHeight is 0, the property is ignored. If the FormMaxHeight property is greater than 0, the user cannot resize the form such that the form's height is greater than the FormMaxHeight property. Use the FormMinHeight to set the minimum height for the form.


property FormMaxWidth

property Resizer.FormMaxWidth as Single
Retrieves or sets a value that indicates the maximum form width.

Type | Description
Single | A numeric value that indicates the maximum width for the form, in form coordinates.
The FormMaxWidth property specifies the maximum width for the form. If the FormMaxWidth is 0, the property is ignored. If the FormMaxWidth property is greater than 0, the user cannot resize the form such that the form's width is greater than the FormMaxWidth property. Use the FormMinWidth to set the minimum Width for the form.


property FormMinHeight

property Resizer.FormMinHeight as Single
Retrieves or sets a value that indicates the minimum form height.

Type | Description
Single | A numeric value that indicates the minimum height of the form, in form coordinates.

The FormMinHeight property specifies the minimum height for the form. If the FormMinHeight is 0, the property is ignored. If the FormMinHeight property is greater than 0, when the form is resized, the height of the form is always greater than FormMinHeight property. Use the FormMaxHeight to set the maximum height for the form.


property FormMinWidth

property Resizer.FormMinWidth as Single
Retrieves or sets a value that indicates the minimum width for the form.

Type | Description
Single | A numeric value that indicates the minimum width of the form, in form coordinates.

The FormMinWidth property specifies the minimum Width for the form. If the FormMinWidth is 0, the property is ignored. If the FormMinWidth property is greater than 0, when the form is resized, the width of the form is always greater than FormMinWidth property. Use the FormMaxWidth to set the maximum width for the form.


property ObjectAnchor

property Resizer.ObjectAnchor(Name as String) as Long
Retrieves or sets a value that indicates the object's anchor value.

Type | Description
Name as String | A string expression that defines the name
Long | A long expression that specifies the object's anchor value


method Refresh

method Resizer.Refresh ()
Refreshes the objects coordinates.

Type Description

Call the Refresh method to refresh the objects coordinates.


method Update

method Resizer.Update ()
Updates the position and size for each anchored control.

Type Description
Use the Update method to update the position and size for each anchored control. By default, the control updates automatically the position and the size of the anchored controls as soon as the user resizes the container.


ExResizer events
Tip The /COM object can be placed on a HTML page (with usage of the HTML object tag: <object classid="clsid:...">) using the class identifier: {95541EA1-31B3-4721-86B0-BBC140C7059A}. The object's program identifier is: "Exontrol.Resizer". The /COM object module is: "ExResizer.dll"
The control has no events.

Name Description


Anchor object
Describes the ExResizer Anchor property page. The Anchor property page lists all components in the container. Each component visible at runtime, can be anchored to the container edges.

Name Description


property ObjectAnchor

property Resizer.ObjectAnchor(Name as String) as Long
Retrieves or sets a value that indicates the object's anchor value.

Type | Description
String | A string expression that indicates the component's name
Long | A long value that indicates the component edges that are anchored to container edges.
The anchor value should be a combination of one or more of the following:
  • 1 - anchored to top
  • 2 - anchored to left
  • 4 - anchored to right
  • 8 anchored to bottom.

For instance the following sample specifies that the Command1 component is anchored to the top and bottom sides of the form:

Resizer1.ObjectAnchor("Command6") = 9.