Exontrol.ExLookupNS - Information, Features

ExLookupNS

The ExLookupNS COM object is a DNS (Domain Name Service) component that can be used for network diagnosing, troubleshooting, and monitoring. The ExLookpNS allows developers to integrate the DNS protocol message sending capability into their applications. The ExLookupNS's object model is rich, flexible and very intuitive. For instance, the statement .Query("exontrol.com").MailExchange gives you the list of mail servers. It is fully compliant with RFC 1034, RFC 1035, RFC 1876 and RFC 1886

Here's the list of supported DNS record types:

  • AAAA records(IPv6 addresses)
  • A(Address)
  • NS(NameServer)
  • MD(MailDestination)
  • MF(MailForwarder)
  • CNAME(CanonicalName)
  • SOA(ZoneOfAuthority)
  • MB(MailBoxDomainName)
  • MG(MailbogGroupMember)
  • MR(MailRenameDomainName)
  • WKS(WellKnwonService)
  • PTR(DomainNamePointer)
  • HINFO(HostInformation)
  • MINFO(MailInformation)
  • MX(MailExchange)
  • LOC(Location)

The ExLookupNS component automatically detects configured DNS servers

® ExLookupNS is a trademark of Exontrol. All Rights Reserved.


Exontrol - Support

How to get support?

To keep your business applications running, you need support you can count on.

Here are few hints what to do when you're stuck on your programming:

  • Check out the samples - they are here to provide some quick info on how things should be done
  • Check out the how-to questions using the eXHelper tool
  • Check out the help - includes documentation for each method, property or event
  • Check out if you have the latest version, and if you don't have it send an update request here.
  • Submit your problem(question) here.

Don't forget that you can contact our development team if you have ideas or requests for new components, by sending us an e-mail at support@exontrol.com ( please include the name of the product in the subject, ex: exgrid ) . We're sure our team of developers will try to find a way to make you happy - and us too, since we helped.

Regards,
Exontrol Development Team

https://www.exontrol.com


constants QueryClassEnum
Specifies the type of the query being sent to a DNS server. Use the QueryClass property to specify the type of the DNS query.

Name | Value | Description
Internet | 1 | Internet (IN)
CSNET | 2 | CSNET (CS)
Chaos | 3 | Chaos (CH)
Hesiod | 4 | Hesiod (HS)
ANYCLASS | 255 | ANYCLASS


HostInformation object
The HostInformation object holds information about a host ( HINFO ). Use the HostInformation property to access the host information. The HINFO records are used to acquire general information about a host. The main use is for protocols such as FTP that can use special procedures when talking between machines or operating systems of the same type.

The following sample prints information about a host:

Dim n As New LookupNS
MsgBox n.Query("info.name-services.com").HostInformation.CPU

The HostInformation object supports the following properties and methods:

Name | Description
CPU | Specifies the type of the host's CPU.
OS | Specifies the host's operating system.


property CPU

property HostInformation.CPU as String
Specifies the type of the host's CPU.

Type | Description
String | A string expression that indicates the CPU used by the host.

The CPU property retrieves the CPU used by the host. The Standard values for CPU and OS can be found in RFC-1010. Use the HostInformation property to access the HINFO record. HINFO records are used to acquire general information about a host. The main use is for protocols such as FTP that can use special procedures when talking between machines or operating systems of the same type.


property OS

property HostInformation.OS as String
Specifies the host's operating system.

Type | Description
String | A string expression which specifies the operating system type.

The Standard values for CPU and OS can be found in RFC-1010. Use the HostInformation property to access the HINFO record. HINFO records are used to acquire general information about a host. The main use is for protocols such as FTP that can use special procedures when talking between machines or operating systems of the same type.


Location object
The Location object holds the location information about hosts, networks, and subnets. Use the Location property to access the Location object. This RFC 1876 defines the format of a new Resource Record (RR) for the Domain Name System (DNS), and reserves a corresponding DNS type mnemonic (LOC) and numerical code (29).

The following sample displays location information of the host:

Dim n As New LookupNS
With n.Query("yahoo.com").Location
    Debug.Print "Latitude " & .Latitude
    Debug.Print "Longitude " & .Longitude
    Debug.Print "Altitude " & .Altitude
End With

The Location object supports the following properties and methods:

Name | Description
Altitude | Retrieves the altitude of the center of the sphere described by the Size property, in centimeters.
HorizontalPrecision | Specifies the horizontal precision of the data, in centimeters.
Latitude | Specifies the latitude of the center of the sphere described by the Size property, in thousandths of a second of arc.
Longitude | Retrieves the longitude of the center of the sphere described by the Size property, in thousandths of a second of arc, rounded away from the prime meridian.
Size | The diameter of a sphere enclosing the described entity, in centimeters.
Version | Retrieves the Version number of the representation.
VerticalPrecision | Specifies the vertical precision of the data, in centimeters.


property Altitude

property Location.Altitude as Long
Retrieves the altitude of the center of the sphere described by the Size property, in centimeters.

Type | Description
Long | A long expression that indicates the altitude of the center of the sphere described by the Size property, in centimeters.

The altitude of the center of the sphere described by the Size property. [RFC 1876]


property HorizontalPrecision

property Location.HorizontalPrecision as Long
Specifies the horizontal precision of the data, in centimeters.

Type | Description
Long | A long expression that indicates the horizontal precision of the data, in centimeters.

The HorizontalPrecision property gives the horizontal precision of the data, in centimeters. This is the diameter of the horizontal "circle of error", rather than a "plus or minus" value. (This was chosen to match the interpretation of Size; to get a "plus or minus" value, divide by 2.) [RFC 1876]


property Latitude

property Location.Latitude as Long
Specifies the latitude of the center of the sphere described by the Size property, in thousandths of a second of arc.

Type | Description
Long | A long expression that specifies the latitude of the center of the sphere described by the Size property, in thousandths of a second of arc.

The latitude of the center of the sphere described by the Size property, expressed as a 32-bit integer, most significant octet first (network standard byte order), in thousandths of a second of arc. 2^31 represents the equator; numbers above that are north latitude. [RFC 1876]


property Longitude

property Location.Longitude as Long
Retrieves the longitude of the center of the sphere described by the Size property, in thousandths of a second of arc, rounded away from the prime meridian.

Type | Description
Long | A long expression that specifies the longitude of the center of the sphere described by the Size property, in thousandths of a second of arc, rounded away from the prime meridian.

The longitude of the center of the sphere described by the Size property, expressed as a 32-bit integer, most significant octet first (network standard byte order), in thousandths of a second of arc, rounded away from the prime meridian. 2^31 represents the prime meridian; numbers above that are east longitude. [RFC 1876]


property Size

property Location.Size as Long
The diameter of a sphere enclosing the described entity, in centimeters.

Type | Description
Long | A long expression that specifies the diameter of a sphere enclosing the described entity, in centimeters.

The Size property indicates the diameter of a sphere enclosing the described entity, in centimeters. [RFC 1876].


property Version

property Location.Version as Long
Retrieves the Version number of the representation.

Type | Description
Long | A long expression that indicates the Version number of the representation.

Version number of the representation. This must be zero. Implementations are required to check this field and make no assumptions about the format of unrecognized versions. [RFC 1876]


property VerticalPrecision

property Location.VerticalPrecision as Long
Specifies the vertical precision of the data, in centimeters.

Type | Description
Long | A long expression that specifies the vertical precision of the data, in centimeters.

The VerticalPrecision is the total potential vertical error, rather than a "plus or minus" value. Note that if altitude above or below sea level is used as an approximation for altitude relative to the ellipsoid, the precision value should be adjusted.


LookupNS object
The ExLookupNS COM object is a DNS (Domain Name Service) component that can be used for network diagnosing, troubleshooting, and monitoring. The ExLookpNS allows developers to integrate the DNS protocol message sending capability into their applications. The ExLookupNS's object model is rich, flexible and very intuitive. The ExLookupNS component automatically detects configured DNS servers.

The following sample displays the IP address(es) of the host:

Dim n As New LookupNS
MsgBox n.Query("yahoo.com").Address

The LookupNS object supports the following properties and methods:

Name | Description
Debug | Retrieves a string for debug purpose.
DefaultServer | Retrieves the default DNS server.
LastError | Retrieves a value that indicates the last error occurred.
LastErrorCode | Retrieves the code of the last error.
Port | Retrieves or sets a value that indicates the port to send query on. By default is 53.
Query | Retrieves a Message object that contains information about the Host.
QueryClass | Retrieves or sets the class of the query.
Separator | Retrieves or sets a value that indicates the string expression used to separate multiple values.
Server | Retrieves or sets a value that indicates the default server.
TimeOut | Specifies the amount of time (in seconds) the control will wait for the server response.


property Debug

property LookupNS.Debug as Variant
Retrieves a string for debug purpose.

Type | Description
Variant | A string expression that indicates a debugging string.

Only for internal use. The Debug property is implemented only by Debug configuration.


property DefaultServer

property LookupNS.DefaultServer as String
Retrieves the list of local DNS servers.

Type | Description
String | A string expression that indicates the list of DNS servers.

The DefaultServer property retrieves the list of local DNS servers. The list includes the 'Preferred DNS server' and the 'Alternate DNS server'. The list of servers is delimited by the Separator property. The queries are sent to the DNS Server. Use the Server property to specify a new DNS server.

The following sample displays the "Preferred DNS Server".

Dim n As New LookupNS
n.Separator = Chr(0)
MsgBox n.DefaultServer

The following sample displays the list of all local DNS servers:

Dim n As New LookupNS
MsgBox n.DefaultServer


property LastError

property LookupNS.LastError as String
Retrieves a value that indicates the last error occurred.

Type | Description
String | A string expression that indicates the last error occurred.

If sending the query to a DNS server fails, or the DNS server fails to reply with an answer, the LastError and LastErrorCode properties indicates the error that occurs. The LastErrorCode property gets the code of the last error occurred.

The list of NS errors is:

Code | NS Error Description
32001 | The name server was unable to process the query.
32002 | The name server was unable to process the query due a problem with the name server.
32003 | The host does not exist.
32004 | The name server does not support the requested kind of query.
32005 | The name server refuses to perform the specified operation for policy reasons

The most frequent error that might appear is 32003 ( The host does not exist.).


property LastErrorCode

property LookupNS.LastErrorCode as Long
Retrieves the code of the last error.

Type | Description
Long | A long expression that indicates the code of the last error.

If sending the query to a DNS server fails, or the DNS server fails to reply with an answer, the LastError and LastErrorCode properties indicates the error that occurs. The LastError property gets the description of the last error. Use the LastError or LastErrorCode property to get the last error, if the DNS answer is empty.

For instance, the following sample generates an error, and so the DNS answer is empty:

Dim n As New LookupNS
Debug.Print n.Query("micro^soft.com").Address
MsgBox n.LastError

The sample generates the error: "The host doesn't not exist. ". In this case, the Address property retrieves an empty string.


property Port

property LookupNS.Port as Long
Retrieves or sets a value that indicates the port to send query on.

Type | Description
Long | A long expression that indicates the port being used to query the DNS server.

By default, the Port property is 53. Use the Server property to change the DNS server queried.


property Query

property LookupNS.Query (Host as String) as Message
Retrieves a Message object that contains information about the Host.

Type | Description
Host as String | A string expression that indicates the host name or the IP address.
Message | A Message object that contains information about a host.

The Query property prepares the query to be sent to a DNS server. Use the QueryClass property to specify the class of the query being sent to a DNS server. Important note! The query is sent to the DNS Server only when one of the Message object properties is accessed.

For instance, the following sample asks the DNS server about the IP address of the host:

Dim n As New LookupNS
MsgBox n.Query("microsoft.com").Address

The following sample doesn't send a query to the DNS server, because none of the Message object properties is accessed.

Dim n As New LookupNS, q As Message
Set q = n.Query("microsoft.com")

The following sample sends the query to a DNS server when Address property is called:

Dim n As New LookupNS, q As Message
Set q = n.Query("microsoft.com")
MsgBox q.Address


property QueryClass

property LookupNS.QueryClass as QueryClassEnum
Retrieves or sets the class of the query.

Type | Description
QueryClassEnum | A QueryClassEnum expression that indicates the type of the query being sent to a DNS server.

By default, the QueryClass property is Internet (1). Use the Query property to prepares a query to be sent to a DNS server. The QueryClass property should be called before calling the Query property.


property Separator

property LookupNS.Separator as String
Retrieves or sets a value that indicates the string expression used to separate multiple values.

Type | Description
String | A string expression that indicates the separator being used in few properties of the Message object.

By default, the Separator property is "\r\n" (vbCrLf). Important Note! In the DEMO version, the Separator property is not implemented.

The following sample shows how to get only the first value, if the message contains multiple values:

Dim n As New LookupNS
n.Separator = Chr(0)
MsgBox n.Query("microsoft.com").Address

The Separator property splits multiple values in the following properties:

  • DefaultServer property of the LookupNS object.
  • AAAA property of the Message object
  • Address property of the Message object
  • CanonicalName property of the Message object
  • DomainNamePointer property of the Message object
  • MailBoxDomainName property of the Message object
  • MailDestination property of the Message object
  • MailExchange property of the Message object
  • MailForwarder property of the Message object
  • MailGroupMember property of the Message object
  • MailRenameDomainName property of the Message object
  • NameServer property of the Message object


property Server

property LookupNS.Server as String
Retrieves or sets a value that indicates the default server.

Type | Description
String | A string expression that indicates the DNS being queried.

The Server property defines the DNS server where the queries are sent. By default, the Server property is the preferred DNS server. Use the DefaultServer property to get the preferred DNS server. Use the Port property to specify the port being used. The TimeOut property gets or sets the length of time until the query times out.

The following sample changes the DNS server and queries for a MX records:

Dim n As New LookupNS
n.Server = "dns1.cp.msft.net"
MsgBox n.Query("microsoft.com").MailExchange


property TimeOut

property LookupNS.TimeOut as Long
Specifies the amount of time (in seconds) the control will wait for the server response.

Type | Description
Long | A long expression that indicates the amount of time the control will wait for the server response, in seconds.

By default, the TimeOut property is 5 seconds. Use the Server property to specify a DNS server.


MailInformation object
The MailInformation object holds mail list information. Use the MailInformation property to access the MailInformation object. The MailInformation object handles the MINFO structures described in the RFC 1035. The MailInformation object supports the following properties and methods:

Name | Description
ErrorMailBox | Specifies a mailbox which is to receive error messages related to the mailing list or mailbox.
ResponsibleMailBox | Specifies a mailbox which is responsible for the mailing list or mailbox.


property ErrorMailBox

property MailInformation.ErrorMailBox as String
Specifies a mailbox which is to receive error messages related to the mailing list or mailbox.

Type | Description
String | A string expression specifies a mailbox which is to receive error messages related to the mailing list or mailbox.

The ErrorMailBox property retrieves a domain name which specifies a mailbox which is to receive error messages related to the mailing list or mailbox specified by the owner of the MINFO record. If this domain name names the root, errors should be returned to the sender of the message.


property ResponsibleMailBox

property MailInformation.ResponsibleMailBox as String
Specifies a mailbox which is responsible for the mailing list or mailbox.

Type | Description
String | A string expression that specifies a mailbox which is responsible for the mailing list or mailbox.

The ResponsibleMailBox property retrieves a domain name which specifies a mailbox which is responsible for the mailing list or mailbox. If this domain name names the root, the owner of the MINFO record is responsible for itself.


Message object
The Message object holds a DNS response. Use the Query property to get a Message object. The control sends the query to the DNS Server when one of the Message object properties is invoked.

The following sample displays the mail servers responsible for the host, in the mail server preference order:

Dim n As New LookupNS
MsgBox n.Query("microsoft.com").MailExchange

The Message object supports the following properties and methods:

Name | Description
AAAA | Retrieves the IPv6 address.
Address | Retrieves the host IP address(es). The list is separated by Separator.
CanonicalName | Retrieves a value that specifies the canonical or primary name for the host.
DomainNamePointer | Retrieves a value that indicates the domain name pointer of the host.
HostInformation | Retrieves information about a host.
Location | Retrieves the location where the host is located.
MailBoxDomainName | Retrieves the domain name that specifies a host that has a specified mailbox.
MailDestination | Specifies a host which has a mail agent for the domain which should be able to deliver mail for the domain.
MailExchange | Retrieves a list of mail servers for the Host, ordered by preferences, and separated by Separator.
MailForwarder | Retrieves a domain name which specifies a host which has a mail agent for the domain which will accept mail for forwarding to the domain.
MailGroupMember | Specifies a mailbox which is a member of the mail group specified by the domain name.
MailInformation | Retrieves a mailbox or mail list information.
MailRenameDomainName | Specifies a mailbox which is the proper rename of the specified mailbox.
NameServer | Retrieves the host's name server.
WellKnownService | Retrieves description for a well known service.
ZoneOfAuthority | Specifies the start of the zone of authority for the host.


property AAAA

property Message.AAAA as String
Retrieves the IPv6 address.

Type | Description
String | A string expression that indicates the list of the IPv6 addresses.

The RFC 1886 describes the AAAA records. If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.

The following sample displays IPv6 address(es) for the host:

Dim n As New LookupNS
MsgBox n.Query("dot.ep.net").AAAA


property Address

property Message.Address as String
Retrieves the host IP address(es).

Type | Description
String | A string expression that indicates the IP address(es) for the host.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.

The following sample displays the IP addresses for the host:

Dim n As New LookupNS
MsgBox n.Query("www.microsoft.com").Address


property CanonicalName

property Message.CanonicalName as String
Retrieves a value that specifies the canonical or primary name for the host.

Type | Description
String | A string expression that specifies the canonical or primary name for the host.

The CanonicalName property retrieves a domain name which specifies the canonical or primary name for the host. If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.

The following sample displays the alias for the host:

Dim n As New LookupNS
MsgBox n.Query("www.microsoft.com").CanonicalName


property DomainNamePointer

property Message.DomainNamePointer as String
Retrieves a value that indicates the domain name pointer of the host.

Type | Description
String | A string expression that indicates the domain name pointer of the host.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.


property HostInformation

property Message.HostInformation as HostInformation
Retrieves information about a host.

Type | Description
HostInformation | A HostInformation object that holds information about a host.

Use the HostInformation property to get the CPU or OS of the host.


property Location

property Message.Location as Location
Retrieves the location where the host is located.

Type | Description
Location | A Location object that contains the location of the host.

Use the Location property to retrieve the location of the host.


property MailBoxDomainName

property Message.MailBoxDomainName as String
Retrieves the domain name that specifies a host that has a specified mailbox.

Type | Description
String | A string expression that retrieves the domain name that specifies a host that has a specified mailbox.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.


property MailDestination

property Message.MailDestination as String
Specifies a host which has a mail agent for the domain which should be able to deliver mail for the domain.

Type | Description
String | A string expression that specifies a host which has a mail agent for the domain which should be able to deliver mail for the domain.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.


property MailExchange

property Message.MailExchange as String
Retrieves a list of mail servers for the Host, ordered by preferences.

Type | Description
String | A string expression that indicates the list of mail servers for the Host, ordered by preferences.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.

The following sample displays the list of mail servers for the host:

Dim n As New LookupNS
MsgBox n.Query("ftp.exontrol.net").MailExchange


property MailForwarder

property Message.MailForwarder as String
Retrieves a domain name which specifies a host which has a mail agent for the domain which will accept mail for forwarding to the domain.

Type | Description
String | A string expression that indicates the domain name which specifies a host which has a mail agent for the domain which will accept mail for forwarding to the domain.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.


property MailGroupMember

property Message.MailGroupMember as String
Specifies a mailbox which is a member of the mail group specified by the domain name.

Type | Description
String | A string expression that specifies a mailbox which is a member of the mail group specified by the domain name.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.


property MailInformation

property Message.MailInformation as MailInformation
Retrieves a mailbox or mail list information.

Type | Description
MailInformation | A MailInformation object that holds mail information.

Use the MailInformation property to get the mail information.


property MailRenameDomainName

property Message.MailRenameDomainName as String
Specifies a mailbox which is the proper rename of the specified mailbox.

Type | Description
String | A string expression that specifies a mailbox which is the proper rename of the specified mailbox.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values.


property NameServer

property Message.NameServer as String
Retrieves the host's name server.

Type | Description
String | A string expression that indicates the host's name servers.

If the DNS response contains multiple values, the Separator property determines the delimiter for the list of values. Important Note! The DEMO version retrieves only one or two name servers for the host. The DEMO version does not retrieve the entire list of name servers for the host.


property WellKnownService

property Message.WellKnownService as WellKnownService
Retrieves description for a well known service.

Type | Description
WellKnownService | A WellKnownService object that holds the description for a well known service.

Use WellKnownService record record is used to describe the well known services supported by a particular protocol on a particular internet address.


property ZoneOfAuthority

property Message.ZoneOfAuthority as ZoneOfAuthority
Specifies the start of the zone of authority for the host.

Type | Description
ZoneOfAuthority | A ZoneOfAuthority object that marks the start of a zone of authority.

The ZoneOfAuthority property handles the SOA records.


WellKnownService object
Use WellKnownService record record is used to describe the well known services (WKS) supported by a particular protocol on a particular internet address. Use the WellKnownService property to access the WKS records. The WellKnownService object supports the following properties and methods:

Name | Description
Address | Retrieves the IP address for the well known service.
Bitmap | Retrieves an array of bytes that are one bit per port for specified protocol.
Protocol | Specifies the protocol number.


property Address

property WellKnownService.Address as String
Retrieves the IP address for the well known service.

Type | Description
String | A string expression that indicates the IP address for a well known service.

The WKS record is used to describe the well known services supported by a particular protocol on a particular internet address. The Protocol property specifies an IP protocol number, and the Bitmap property has one bit per port of the specified protocol.


property Bitmap

property WellKnownService.Bitmap as SAFEARRAY FAR*
Retrieves an array of bytes that are one bit per port for specified protocol.

Type | Description
SAFEARRAY FAR* | A safe array of bytes that are one bit per port for specified protocol.

The WKS record is used to describe the well known services supported by a particular protocol on a particular internet address. The Protocol property specifies an IP protocol number, and the Bitmap property has one bit per port of the specified protocol.


property Protocol

property WellKnownService.Protocol as Long
Specifies the protocol number.

Type | Description
Long | A long expression that indicates the protocol number.

The WKS record is used to describe the well known services supported by a particular protocol on a particular internet address. The Protocol property specifies an IP protocol number, and the Bitmap property has one bit per port of the specified protocol.


ZoneOfAuthority object
The ZoneOfAuthority object handles the SOA records. The SOA record marks the start of a zone of authority. Use the ZoneOfAuthority property to access the SOA records. The ZoneOfAuthority object supports the following properties and methods:

Name | Description
Expire | Retrieves the time value that specifies the upper limit on the time interval that can elapse before the zone is no longer authoritative.
MailboxServerName | Specifies the mailbox of the person responsible for this zone.
Minimum | Specifies the time to live for this record.
PrimaryNameServer | Specifies the name server that was the original or primary source of data for this zone.
Refresh | Specifies the time interval before the zone should be refreshed.
Retry | Specifies the time interval that should elapse before a failed refresh should be retried.
Serial | Specifies the version number of the original copy of the zone. Zone transfers preserve this value. This value wraps and should be compared using sequence space arithmetic.


property Expire

property ZoneOfAuthority.Expire as Long
Retrieves the time value that specifies the upper limit on the time interval that can elapse before the zone is no longer authoritative.

Type | Description
Long | A long expression that indicates the time value that specifies the upper limit on the time interval that can elapse before the zone is no longer authoritative.

The Expire property handles the EXPIRE field of the SOA record.


property MailboxServerName

property ZoneOfAuthority.MailboxServerName as String
Specifies the mailbox of the person responsible for this zone.

Type | Description
String | A string expression that specifies the mailbox of the person responsible for this zone.

The MailBoxServerName property handles the RNAME field of the SOA record.


property Minimum

property ZoneOfAuthority.Minimum as Long
Specifies the time to live for this record.

Type | Description
Long | A long expression that indicates the time to live for this record.

The Minimum property handles the MINIMUM field of the SOA record.


property PrimaryNameServer

property ZoneOfAuthority.PrimaryNameServer as String
Specifies the name server that was the original or primary source of data for this zone.

Type | Description
String | A string expression that specifies the name server that was the original or primary source of data for this zone.

The PrimaryNameServer property handles the MNAME field of the SOA record.


property Refresh

property ZoneOfAuthority.Refresh as Long
Specifies the time interval before the zone should be refreshed.

Type | Description
Long | A long expression that specifies the time interval before the zone should be refreshed.

The Refresh property handles the REFRESH field of the SOA record.


property Retry

property ZoneOfAuthority.Retry as Long
Specifies the time interval that should elapse before a failed refresh should be retried.

Type | Description
Long | A long expression that indicates the time interval that should elapse before a failed refresh should be retried.

The Retry property handles the RETRY field of the SOA record.


property Serial

property ZoneOfAuthority.Serial as Long
Specifies the version number of the original copy of the zone.

Type | Description
Long | A long expression that indicates the version number of the original copy of the zone.

Zone transfers preserve this value. This value wraps and should be compared using sequence space arithmetic. The Serial property handles the SERIAL field of the SOA record.